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Welcome to FlashCORE III 
Programming Engine – Desktop Model
The FlashCORE Desktop is Data I/O’s desktop version programming engine. 
Designed for programming first article builds to confirm functionality prior 
to high-volume production runs, it is the same programming engine used in 
the PSV7000 for seamless transfer from Engineering to Operations. 

Scope of this Guide
Getting started with the FlashCORE III Desktop Model covers these topic:
   • Setup FlashCORE III Desktop,    • Install Software,  
   • Configure the Network,   • Get Algorithms from Data I/O, 
   • Create a Job,    • Run a Job, and    • Troubleshooting tips.
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Getting Started

DESKTOP



Contents of the Desktop Model
1. FlashCORE III (FC III) Desktop Programmer
2. Vacuum Tool Kit
3. Power Cable
4. Ethernet Cable
5. TaskLink and PS software CDs (vary depending on PS System)
6. Customer Service Letter 983-XXXX-001 and conformance documents

Figure 1: Contents of FlashCORE III Desktop. Ensure that the 
CDs match the PS System you have. PSV7000 and AH700 CDs 
shown here.
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Requirements
Computer requirements (for TaskLink)
operaTing sysTem: Windows 7 (32 or 64 bit), with Administrative Permissions
Hard disk space: 90 MB minimum for Algorithm files and the two applications;  
    • also additional space for the jobs you create.
a cd drive
Two eTHerneT porTs:
 Access to your Corporate LAN / Internet access
 A 100 Mbps NIC (dedicated, private, Static IP Address) for FlashCORE III, 
or a 1 Gbps NIC with auto-negotiation. (For more information search the 
Web for How to install a second Network Adapter card.)
opTionaL Hardware: 100 Mbps Ethernet switch box if networking more than 
one programmer (each programmer must have a unique IP address).

Getting Started

CAUTION: Electrostatic Discharge Hazard!  
Electrostatic Discharge (ESD) may damage equipment 
and integrated circuits. Discharge static electricity to a 
common ground. Use ESD prevention devices that contain 
a 1 M-ohm to 10 M-ohm current limiting resistor.

WARNING: Electric Shock Hazard! 
Injury or death may result from contact to parts inside the 
programmer. Do not remove covers. No user serviceable 
parts.

eleCtriCal requirements
operaTing voLTage: 110–240 VAC
power consumpTion: 100 watts max
frequency range: 50 to 60 Hz

environmental requirements
operaTing TemperaTure: +10° to +30° C  
  (50° to 86° F)
HumidiTy: ≤ 90% 

programming requirements
Your target device(s) 
At least one Socket Adapter for that  
 device
A FlashCORE III Algorithm for that 
device
A ground connection
A 4 mm hex key (Allen wrench)
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1. Set Up & Configure FlashCORE III Hardware
1-1. Plug the power cable into the FlashCORE III and into a 120-240 VAC 

outlet. 
1-2. Connect the Ethernet cable between the PC and the programmer.
1-3. Recommended: Plug in a wrist ground strap to prevent electrostatic 

discharge.
1-4. To install a Socket Adapter, unscrew the two captive, socket head 

screws (4 mm hex key) and open the adapter bracket..

CAUTION: Possible machine damage! Bent or damaged 
pins can reduce yields or prevent programming. Do not 
touch connector pins. 

1-5. Insert the correct Socket Adapter, making sure that it seats on the 
dowel pins. NOTE: don’t touch the gold contacts on the bottom of the 
adapter.

Figure 2: FC Desktop without Socket Adapter. 
Bracket is open exposing the dowel pins (arrows). .
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NOTE: The correct adapter can be confirmed on the Data I/O 
website. On our website: 1) Click Support > Device Support, 2) 
Type in your device PN and Search for Devices. 3) Select your 
device from the list and see adapter PNs in the right column.

1-6. Close the socket bracket and screw in the two screws.
1-7. Using the vacuum tool supplied, insert your target device(s) into the 

socket(s).

Figure 3: Socket Adapter is installed and bracket tightened..  
Devices have also been installed in this view.
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2. Install Data I/O Software

NOTE: Administrative Permissions are required to continue.  
To check if you have Admin Permissions: 
1. Open the Control Panel.  
2. When viewing by Category (versus icons) click System and  
 Security > Administrative Tools > Computer Management.  
3. Expand Local User and Groups and click Groups.  
4. Double-click Administrators. 
5. Verify that your login name is in the Members list. If not click  
 Add and enter the data, or if you don’t have permissions, con-
tact your administrator.

2-1. At a PC with Windows 7 running, 
insert the AH700 or AH500 CD (which-
ever is applicable) and right-click 
Setup.exe > Run As Administrator. 
Follow the on-screen instructions. 
Accept all defaults except hardware 
files (which are not required for the 
Desktop programmer). To do that, 
uncheck the box for PSV7000 [or PS 
System] Hardware (this includes 
Vision files, Automatic Tray Feeder 
files, and others).

2-2. Insert the TaskLink CD and right-click Setup.exe > Run As Adminis-
trator. Follow the on-screen instructions.

2-3. In Explorer, navigate to the winah400.ini file; for example, with the 
PSV7000, the path is C:\AH700\winah400.ini. Then rename it 
to something else such as winah400-Orig.ini. Note that your 
Explorer might be set to hide the extensions.

2-4. In the same folder find file winah400_simulator.ini and rename 
it to winah400.ini. 

NOTE: Do not open this file in Microsoft Word or other word pro-
cessing software.
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2-5. Edit the winah400.ini file in Notepad or UltraEdit to make the follow-
ing changes:

   Change RRFlashPgmr= to 1
   Add a semi-colon in front of Viper=4,6
   Add BatchMode=True
   Change TotalProgrammers= to 1
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3. Configure FC III Network Connection
Configure the Host PC’s network adapter (NIC) for a static Ethernet connec-
tion to the programmer.

3-1. With your target Socket Adapter installed and the power cable 
plugged in, turn ON the power switch on the side of the programmer.

NOTE: Before proceeding, wait until the red LED at each socket 
blinks once to indicate that the startup procedure has com-
pleted. 

3-2. Open the Windows Control Panel and click Network and Internet > 
Network and Sharing Center.

3-3. Click Change Adapter Settings.
3-4. Right click the Local Area Connection (for the FlashCORE Desktop 

programmer) > Properties.
3-5. Select Internet Protocol Version 4 (TCP/IPv4) from the list and click 

Properties.

Figure 4: Network Settings.
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3-6. Select Use the following IP address. 
3-7. Enter IP address  192.168.1.250 (and Subnet mask  255.255.248.0 if 

it doesn’t auto-fill).
3-8. Click OK and Close, and close the Control Panel window.

ConneCt tasklink CommuniCation as follows:
3-9. Start TaskLink (double click the desktop icon). If asked   

to allow TaskLink through the firewall, click OK.

3-10. Set the programming system to your  
PS System. (If the TaskLink Startup Wiz-
ard opens, click Select Programming 
System > OK, then select your PS Sys-
tem and click OK.)

3-11. Click System > Options > Communication tab. 
3-12. Click Locate and then Yes (to delete programmers from the list). See 

the figure below.
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3-13. After it’s located, select the programmer and click OK.
3-14. Highlight the programmer—see Figure 5—and click Assign Site.
3-15. (Optional) Click Toggle LEDs to check connection. (Socket LEDs will 

blink).
3-16. Select a site number and click OK. And OK again to close the dialog.
3-17. Close TaskLink.
For more information see Assigning Programmer Site Numbers in Task-
Link’s online Help.

Figure 5: The TaskLink Communication tab dis-
plays Network Settings. The IP Address for each 
programmer is listed in the lower left corner.
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4. FlashCORE III Connectivity

Prerequisite: Your target Socket Adapter is installed, the power 
cable and Ethernet cable are plugged in, and the power is ON.

4-1. Open the Windows command prompt application (cmd.exe) via the 
Start menu or keyboard shortcut.

4-2. Type  ping 192.168.1.1 and press Return. Note that this pro-
grammer IP address is different from the NIC address.

4-3. If there is a reply from the FlashCORE III programmer, connectivity is 
good. Refer to the figure below.

4-4. Exit the cmd.exe window.

Figure 6: Examples of communication success and failure in 
cmd.exe. If yours failed, see Troubleshooting later in this docu-
ment.
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5. Download Algorithms from Data I/O
5-1. Close TaskLink before downloading and installing algorithms.
5-2. In a browser, navigate to the Data I/O home page (www.dataio.com) 

click Support> Software & Firmware.
5-3. Adjacent to PS Series click more. 
5-4. Click PS Series Download and Save.

5-5. Find the downloaded file (for example: P3_C.exe) and double-click it to 
start the installation process.

5-6. Click Yes to the Windows User Account Control dialog.
5-7. When the InstallShield Wizard displays click Next to install the (Keep) 

Current algorithms. Refer to the image below.

Figure 7: Navigating the Data I/O website to the Download 
page.
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5-8. Click Finish.
5-9. If a Windows message displays reading This program might not 

have installed correctly, click This program installed correctly.

NOTE: If you want to check for a specific algorithm, follow the 
next step. Otherwise, you can skip to Create a Job and Run it.

5-10. (Optional) To check for new algorithms, go to Device Search Engine 
on the Device Support page of our Data I/O website.

5-11. (Optional) After the list on the right updates, click Download All to 
download files to  C:\Dataio\Tlwin\PSSeries\PS_Algs.

5-12. (Optional) Close the Updater with the X in the upper right corner.
5-13. At the Settings dialog, click Close.

Congratulations. You are ready to program.

Figure 8: The Keep Current algorithms are all algorithms 
added to our database in the last four months.
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6. Create a Job and Run it

Creating a Job
6-1. Start TaskLink via the desktop icon.
6-2. Make sure the Programmer Status is PS Systems or PSV7000 as 

applicable. (To change it, at TaskLink’s main window click System > 
Select Programming System.)

6-3. Click Task > Task Manager or the Manage Tasks icon 

NOTE: You need administrative  
privileges to create or edit a task/job. If 
Task Manager opens in operaTor 
dialog, click Admin. 

6-4. Use TaskLink’s online Help for instructions to create a job. Click Help 
> Help Topics. Then at the home page click Create a Task (or find 
Create a Task in the Table of Contents).

Also, a Task file must be created 
if one doesn’t already exist. See 
the same page in the Help (How 
to Create a Task) and see the 
subheadings for the Data File 
tab and Handler File tab.

Figure 9: TaskLink Help file. Two ways to open 
the same topic.
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running a Job
6-5. To run your job (with devices in the sockets), at the Task Manager 

select your job and click Run.
6-6. At the process devices dialog, enter a PASS limit of 1 or [up to the maxi-

mum number of sockets on your current Socket Adapter]. Session ID is 
optional. 

6-7. Click OK. The job downloads and a fooTnoTes dialog opens.
6-8. Click Close to close the fooTnoTes dialog.
6-9. Click Yes to okay the checksum. Your PS System software will open. 

(For example: AH700 opens if TaskLink is set for PSV7000 Program-
ming System.)

6-10. Click Start.
6-11. Click Run in the seTup widow. Supervisor privileges may be required.
6-12. Click Run in the run window and click OK to the socket message.

NOTE: For further PS System Software help, see the on-screen 
Help file (click the question mark).
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If you entered a PASS limit greater than the number of sockets, then AH700 
automatically stops and prompts you to remove the programmed devices 
before inserting blank ones.

results
The Run window displays socket status by color. If a programming error 
occurs, the socket will display red. The LED at each socket on the adapter 
also displays status.

Figure 10: TaskLink’s Run window dis-
plays socket status by color. This image 
shows socket two failed programming.

Figure 11: The illuminated LED at socket two 
indicates that programming has failed.
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Troubleshooting Network Connections
If you have communication issues or receive error messages when program-
ming, follow the steps below to check your network connections.

1. Confirm that you are using the correct FlashCORE Desktop programmer 
IP Address by reading the label on the side of the programmer.

2. Open Windows cmd.exe and ping the programmer:  ping 192.168.1.1.
3. If response is ‘timed out’ then close the PS Software and TaskLink and 

disconnect your network cable from your PC and re-insert it. 
-Ping the programmer again from the command prompt. If the 
request is ‘timed out’ follow steps 6 and 7 below until you receive a 
reply from the programmer.

4. If you are using a 1 Gbps NIC with auto-negotiation, try setting the NIC 
to 100 Mbps.

5. Disable and re-enable your local Network via the control panel.
-Ping the programmer again from the command prompt.

6. Cycle the power on the programmer.
-Ping the programmer again from the command prompt.

7. Power cycle the PC (closing applications and shutting down the usual 
way).

-Disconnect and reconnect the Ethernet cable. 
-Ping the programmer again from the command prompt.

8. Reset the network connection:
Click the Start button >Control Panel >Network and Internet > 
Network and Sharing > Change Adapter Settings.
Right-click Local Area Connection (programmer network) > Disable.
Right-click Local Area Connection again (programmer network) > 
Enable.

Troubleshooting Firewall Issues
If you experience trouble with files getting through your Firewall:

allowing tasklink through
1. Open the Control Panel.
2. When viewing by Category, click System and Security > Windows 

Firewall, and verify that your firewall is On.
3. In the left column click Allow a program or feature through Windows 

Firewall.
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4. If the program names are dimmed (not editable) then click the Change 
Settings button.

5. Scroll down the table to TaskLink and check mark the box in the column 
named Home/Work (Private).

NOTE: If you don’t see TaskLink in the list, click Allow another 
program. Click Browse. Navigate to C:\Dataio\Tlwin, high-
light TLWin.exe and click Add. Then check the boxes mentioned 
above.

allowing ‘ColleCt logs’ through
1. Continue from above, or follow steps 1 through 4 under heading Allow-

ing TaskLink Through.
2. To allow the Collect Logs utility through, click Allow another program.
3. Click Browse and navigate to C:\Program Files\CollectLogs or 

C:\Program Files (x86)\CollectLogs.
4. Highlight Collect_PSV_Series_Logs.exe in the list and click Open.
5. Click Add.
6. Find Collect Logs or Collect Logs PSV in the table and check mark the 

box in the column named Home/Work (Private).
7. Click OK and close the Control Panel.

Figure 12: Confriming the firewall is ON and setting  
programs allowed through.
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Technical Support
Contact Data I/O World Wide Support or your local representative. 

find your loCal representative on our website
Navigate to http://www.dataio.com and click Contact Sales (upper 
right), and then Representative Search. Then follow the instructions.

for quiCk aCCurate support, please provide the following  
information:

• FlashCORE III Desktop Serial number (see label) 
• TaskLink Version (Help > About TaskLink from the main window)
• Programmer Firmware Version (in TaskLink click Tools > View Program-

mer Information)
• Detailed description of the problem you are experiencing (if any)
• Error messages (if any)
• Device manufacturer, part number, package style and number of pins (if 

device related)
• Name, telephone number, address, and e-mail address

the best way to get support is by using our online form.
go to the desired website and CliCk the teChniCal support link  

(or the ContaCt sales link).

  www.dataio.com        www.dataio.de www.dataio.cn
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The worlds most trusted  
programmers

Data I/O has endeavored to ensure that this document is accurate. Data I/O assumes no liability 
for error, or for any incidental, consequential, indirect, or special damages, including but 
without limitation, loss of use, loss or alteration of data, delays, or lost profits or savings, arising 
from the use of this document or the product that it accompanies.

www.dataio.com

flashCore dESKTOP— 
with flashCore iii programming engine— integrates into our  
ps programming and handling systems inCluding psv7000  

for a ConneCted programmering proCess.
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